Another sip of code ?

Reminder : Fedora 17 - Yum - Error - Protected Multilib Versions

| Comments

The other day while working on some resource demanding projects, I decided to run my update.

Mid-installation my whole computer froze and by reflex hit the ctr-C shortcut which killed the installation. Next thing I know yum is now blocked by this error :

Error: Protected multilib versions: zlib-1.2.5-7.fc17.i686 != zlib-1.2.5-6.fc17.x86_64

and it stays stuck like that. The reason is because the installation was interrupted mid-course, yum didn’t cleaned what he already installed and goes into conflict with them.

The solution is to run this command :

package-cleanup --cleandupes

It will remove outdated duplicate packages and unlock the situation.

Source: Fedora Forum